首页 文章 类别 VISION 关于


Mac os 10.10安装valgrind

在Mac Os 10.10上安装Valgrind,使用brew发现不支持当前系统,从官网下载源码编译也提示不支持该系统内核。

Valgrind support for MacOS X 10.10 (Yosemite) 这篇文章中找到了答案,可以从svn拉去最新的代码,最新的代码支持10.10系统。

$ svn co svn://svn.valgrind.org/valgrind/trunk valgrind-trunk
$ cd valgrind-trunk/
$ ./autogen.sh
$ ./configure --prefix=/usr/local
$ make -j8
$ sudo make -j8 install

这样就安装成功了

$ valgrind --version
valgrind-3.11.0.SVN

~END